Applicazione Automator come 'Elementi di Accesso' per 'Connettersi ai server' – I server non vengono visualizzati nella barra laterale del Finder?

Avere un'applicazione Automator come 'Elementi di accesso' per 'connettersi ai server' (AFP).

Al login viene eseguito, collega i server, ma non li aggiunge alla barra laterale del Finder in 'Dispositivi'.

Una volta effettuato l'accesso, disconnessione i server manualmente e quindi eseguire manualmente l'applicazione. I server si collegano e vengono aggiunti alla barra laterale del Finder! Stessa applicazione non modificata.

Hanno cercato di aggiungere una pausa di pochi secondi all'applicazione Automator all'inizio, ma non funziona ancora.

Questa stessa applicazione Automator usava per funzionare in Snow Leopard senza fallire. Ha smesso di lavorare con l'aggiornamento a Lion Mountain. Sono state aperte e ri-salvate l'applicazione utilizzando Automator su Mountain Lion.

Eventuali suggerimenti?

Aggiunto (30-SEP-12) …

Il Finder è stato eseguito direttamente dopo il login e lo script Automator.

Il Finder è stato eseguito direttamente dopo il login e lo script Automator.

Esegui manualmente il command Automator.

Esegui manualmente il comando Automator.

Finder dopo aver eseguito manualmente il programma Automator.

Finder dopo aver eseguito manualmente il programma Automator.

Inoltre, ho appena scoperto qualcosa di nuovo. Durante l'accesso, se apro velocemente il Finder, mentre lo script è in fase di esecuzione, i mapping vengono creati (!), Ma se non apro il Finder, lasciate che lo script venga eseguito, le mappature non vengono create.

Aggiunta (01-OCT-12) …

Soluzione temporanea … aggiungere un 'Get Finder Items Specified' e quindi un 'Open Finder Items' per aprire il Finder prima di tentare di connettersi ai server.

Soluzione